Most mainstream Linux platforms, including Debian 7 (Wheezy), RHEL 6 & 7, CentOS 6 & 7, and Ubuntu 12.04, using versions of the GNU C Library (glibc) from 2.2 to before 2.18 are now known to be vulnerable to a buffer overflow attack.
CVE-2015-0235 details the nature of the vulnerability and how it can be exploited.The gethostbyname() and gethostbyname2() glibc function call could be used to exploit this flaw and execute arbitrary code with the permissions of the user running the application.
Patches are already available so you are advised to run updates now, but if you want to check which version of glibc is installed on your host,
[[email protected] ~]# ldd --version
ldd (GNU libc) 2.12
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.
[[email protected] ~]#
Use System -> Administration -> Software update (example from CentOS 6)
Or simply run a
sudo yum clean all
sudo yum update
Vulnerability management is a key security best practice but must be operated in conjunction with a 'closed loop' of change control, patching, system integrity verification and file integrity change review.
For more information on GHOST, see GHOST Vulnerability CVE-2015-0235